1. Check out the Hot Deals section of the Marketplace forum to order an official Mossbergowners.com hat.

had to call mossberg

Discussion in 'Firearm Maintenance, Safety And Troubleshooting' started by mark5019, Aug 14, 2017.

  1. mark5019

    mark5019 .410

    Messages:
    30
    for my 590a1 as inserting rounds into mag tube was hanging up.
    there sending me new spring and follower, hope thats a fix as i hate to have to send it in
  2. John A.

    John A. Unconstitutional laws are not laws. Staff Member Administrator Global Moderator

    Messages:
    16,638
    Dent, ding, bend in the tube?

    Dropped?

    Fall over out of the closet and smack the dresser?
  3. mark5019

    mark5019 .410

    Messages:
    30
    None of the above brand new out of the box.
    Spring came today will install tomorrow.
    Hope fixes problem
    John A. likes this.
  4. old mossy

    old mossy Global Moderator Staff Member Global Moderator Moderator

    Messages:
    13,094
    I hope it fixes it for you. Be careful when taking off the mag cap that the detent and spring dosen't pop out on you. (some are loose from the factory)

    Keep us posted.

    detent 4 590.jpg
  5. mark5019

    mark5019 .410

    Messages:
    30
    When I bought it barrel was off had to take cap off .
    If it's not the spring, will have to send it to Mossberg
  6. mark5019

    mark5019 .410

    Messages:
    30
    took off cat to put barrel on not see that
  7. RichardL

    RichardL .270 WIN

    Messages:
    137
    Hanging up in what way? Probably a stupid question, but was it "jamming" after you loaded two into the mag tube?
  8. mark5019

    mark5019 .410

    Messages:
    30
    Inserting round in tube when it got to the brass part had to push real hard then it resisted the went in.
    Going to install new spring if not better send into Mossberg
  9. jeff51

    jeff51 .22LR

    Messages:
    14
    Let me know if a new spring fix's your problem. Mine does the same thing. Jeff
  10. old mossy

    old mossy Global Moderator Staff Member Global Moderator Moderator

    Messages:
    13,094
    You haven't mentioned if you tried a different brand ammo????(possible bad batch)????
    mark5019 likes this.
  11. mark5019

    mark5019 .410

    Messages:
    30
    Ok I ran a patch threw it was dirty
    New spring plus light coat oil worked
  12. mark5019

    mark5019 .410

    Messages:
    30
    Well after cleaning tube and new spring sane ammo slides right in.
    RichardL likes this.
  13. old mossy

    old mossy Global Moderator Staff Member Global Moderator Moderator

    Messages:
    13,094
    Glad you got it working.:)
    mark5019 likes this.
  14. jeff51

    jeff51 .22LR

    Messages:
    14
    I cleaned the tube and did not make any difference. I tried three different shells , no difference. Then I compared the cartridge stop with my full sized 590 and the cartridge stop sticks out a lot more on the shockwave than the full sized one. Should I call Mossberg and ask them to send me a new cartridge stop?
  15. mark5019

    mark5019 .410

    Messages:
    30
    call and ask
  16. old mossy

    old mossy Global Moderator Staff Member Global Moderator Moderator

    Messages:
    13,094
    Jeff you need to explain what your problem is with your gun you are having.

    Mark5019's problem had nothing to do with the cartridge stop.
  17. RichardL

    RichardL .270 WIN

    Messages:
    137
    Jeff, try trading the parts in your two guns. If it works, buy a new part. It's cheap on Ebay.
  18. jeff51

    jeff51 .22LR

    Messages:
    14
    I called Mossberg and explained the problem to them and they are sending a new cartridge stop.
    mark5019 likes this.
  19. mark5019

    mark5019 .410

    Messages:
    30
    cool fast delivery also
  20. mark5019

    mark5019 .410

    Messages:
    30
    Well took it shooting not one problem.suvh accurate long gun more I used it easier to load

Share This Page