1. Check out the Hot Deals section of the Marketplace forum to order an official Mossbergowners.com hat.

Rust in the chamber in another 590A1! *UPDATE WITH PIC*

Discussion in 'Mossberg 590 Pump Action' started by LUGI, Jan 12, 2013.

  1. LUGI

    LUGI .270 WIN

    Messages:
    187
    UPDATE AT THE BOTTOM!


    What the hell is going on with mossberg? I bought a 590A1 awhile ago....and had "rust" in the chamber...now just brought another one home with the same "rust like crap" in the chamber.

    What is this...is it rust, how could it be with 2 different guns? Who else has had this issue?
    Really would like to know...if not rust, what could it be.
  2. carbinemike

    carbinemike Global Moderator Staff Member Global Moderator "Philanthropist"

    Messages:
    6,027
    Re: Rust in the chamber in another 590A1!

    Can you post up some pictures?
  3. LAZY EYED SNIPER

    LAZY EYED SNIPER Overwatch Staff Member Global Moderator Supporter "Philanthropist"

    Messages:
    21,109
    Re: Rust in the chamber in another 590A1!

    The same substance has been showing up on mag tubes and other aluminum parts as well. Aluminum doesn't rust, so this has got to be some sort of residue from production or a type of preservative...
  4. old mossy

    old mossy Global Moderator Staff Member Global Moderator Moderator

    Messages:
    12,908
    Re: Rust in the chamber in another 590A1!

    could also be some left over residue from the factory test firing.
  5. LUGI

    LUGI .270 WIN

    Messages:
    187
    Re: Rust in the chamber in another 590A1!


    I will...maybe tomorrow.
  6. LUGI

    LUGI .270 WIN

    Messages:
    187
    Re: Rust in the chamber in another 590A1!

    It's the barrel. Inside just on the chamber...didn't check the rest of it but I think it's just on the that part.
    This isn't the first time dealing with this...so might just call teck support again, and have them send me one until they get it right....but honestly want to know what's the deal with this. :?

    If it is rust.... how can this get past quality control?
  7. Frank Castle

    Frank Castle .270 WIN

    Messages:
    219
    Re: Rust in the chamber in another 590A1!

    Lugi,

    Might not have had rust when it went through QC. I think it depends on how long it sat after boxed, and environment? Anyway to determine this? The rust could develop over time between when they packaged it, and when you opened it. Just a thought.

    Frank
  8. LAZY EYED SNIPER

    LAZY EYED SNIPER Overwatch Staff Member Global Moderator Supporter "Philanthropist"

    Messages:
    21,109
    Re: Rust in the chamber in another 590A1!

    Understood,

    My point is that this substance is also showing up on weapons other than yours on aluminum parts that don't rust. As annoying as it is, this leads me to believe that it isn't rust...
  9. LUGI

    LUGI .270 WIN

    Messages:
    187
    Re: Rust in the chamber in another 590A1!

    I hear ya man.
  10. LUGI

    LUGI .270 WIN

    Messages:
    187
    Re: Rust in the chamber in another 590A1!

    Oh...my bad, sorry. Now I get what you're saying.
  11. LUGI

    LUGI .270 WIN

    Messages:
    187
    Re: Rust in the chamber in another 590A1!

    Here's two pictures.
    Took this about 3 hours.
    [​IMG]
    [​IMG]
    Like i said...this crap is just like my other one, before i got it taking care of....but damn at the money i spent, should not have to go through this! :twisted:
  12. LTB45

    LTB45 .30-06 Rest in Peace Supporter

    Messages:
    1,657
    Pics are not there
  13. LUGI

    LUGI .270 WIN

    Messages:
    187
    I see them....now, do you?
  14. LAZY EYED SNIPER

    LAZY EYED SNIPER Overwatch Staff Member Global Moderator Supporter "Philanthropist"

    Messages:
    21,109
    I see only the top pic.

    Either way, this looks more like the dried cosmoline on my Mosins. Pick up some Birchwood Casey 'Bore Scrubber' or another good solvent and give it a good once over with a bore brush. I can't imagine it'd still be there when you're done...
  15. LTB45

    LTB45 .30-06 Rest in Peace Supporter

    Messages:
    1,657
    I see both pics and agree with LES.
    Looks like some old dried up rust inhibitor like cosmoline.
    Clean it out and if it returns then it is probably rust.
    More likely you will never see it again.
  16. LUGI

    LUGI .270 WIN

    Messages:
    187
    I'll let you guys know what I do.....thanks!
  17. LUGI

    LUGI .270 WIN

    Messages:
    187
    Called today.....spoke to david. He's setting up a prepaid label. He said that he dont think its rust, it
    Is most likely this stuff they put on the barrel and then rinse it in water and it wasn't rinsed all the way.
  18. shellslinger

    shellslinger .410

    Messages:
    58
    I had this in my 590a1 as well. After a few shots it was all gone :D
  19. LUGI

    LUGI .270 WIN

    Messages:
    187

    Really....just like whats in my barrel?
  20. shellslinger

    shellslinger .410

    Messages:
    58
    Yup, except my "rust" spot was on the bottom side of the barrel. Or rather the exact opposite spot as yours.

Share This Page