• Mossberg Owners is in the process of upgrading the software. Please bear with us while we transition to the new look and new upgraded software.

Mossberg 930 Autoloader Troubleshooting

LAZY EYED SNIPER

Overwatch
Global Moderator
Supporter
"Philanthropist"
Re: Had 2 problems with my xps today

Hello Rudy,

Might seem like a dumb question, but we always have to lead off with it. Have you stripped, cleaned, and lubed it yet?
 

Itsricmo

.30-06
Re: 2nd shell wont always fire

Trip, Welcome to Mossberg Owners! I have no experience with a 930 but many members here do! I am more than sure that someone will come along with an idea or an answer to help you out!

Enjoy your time here!
 

LTB45

.30-06
Rest in Peace
Supporter
Re: 2nd shell wont always fire

If you load 1 shell at a time will it ALWAYS go bang on the first pull of the trigger?
 

RUDY850

.22LR
Re: Had 2 problems with my xps today

LAZY EYED SNIPER said:
Hello Rudy,

Might seem like a dumb question, but we always have to lead off with it. Have you stripped, cleaned, and lubed it yet?



when i first got it i did not clean it till after shooting a box of fed bird shot. did not have any problem the first time.

so it was good and clean and well lubed this second time i took it out to shoot.i shot 20 rounds of slugs with only one problem. the lifter stuck up once.then shot about 150 fed bird shot at some clays.the lifter stuck once during that.

after shooting the bird shot is when i tried the 3 inch buck shot and the second one would fall to the ground.then went back to some more bird shot.no problem.

I'm going to try shooting the buck shot first thing next time i take it out. maybe it was to dirty after shooting all the other stuff
 

LTB45

.30-06
Rest in Peace
Supporter
Re: 2nd shell wont always fire

I have no real experience with a 930.
When it comes to Semi Autos I am an 1100 guy.
If my 1100 were to do this, I would be dropping in a new trigger group.

Are you sure that the second shell is seating completely in the barrel?
 

Triplerush

Copper BB
Re: 2nd shell wont always fire

I thought that it was cycling properly and that the second shell was being seated all the way into the barrel. I'm not 100% though, I will have to check that when I take it out this weekend.
 

LTB45

.30-06
Rest in Peace
Supporter
Re: 2nd shell wont always fire

Triplerush said:
I thought that it was cycling properly and that the second shell was being seated all the way into the barrel. I'm not 100% though, I will have to check that when I take it out this weekend.


If that is all true then it would have to be a trigger assembly problem or just maybe your safety is loose, Possibly??? Just guessing with the safety idea.
 

LAZY EYED SNIPER

Overwatch
Global Moderator
Supporter
"Philanthropist"
Re: Had 2 problems with my spx today

You might just try stripping and reassembling again to make sure everything in the action is properly seated in place. The factory gunk can gum up the action, but if you've already cleaned that out you shouldn't have any issues. My 930 shoots just fine dirty...
 

Water Monkey

The man, the myth, the monkey
Moderator
Supporter
Re: Had 2 problems with my spx today **updated with video**

RUDY850 said:
had the SPX out today and had my nephew shooting while I filmed him.
the video shows 3inch buckshot. turkey loads, slugs, and birdshot


heres the link below:

http://www.youtube.com/watch?v=0Del0MD9CYE

Your video had me worried as I haven't shot many 3". Out of her. And when I did it was one at a time.

I have a bunch of magnum turkey loads so I cycled through them while at the range. No failures of any kind. Send that Betty back to mossberg. She's a dud.

Ps

My shoulder hates you.
 

MikeD

I'm Your Huckleberry
Staff member
Administrator
Global Moderator
"Philanthropist"
Re: Had 2 problems with my spx today **updated with video**

The video does make it more clear as to what is happening. You definitely appear to have a timing issue between the elevator and the magazine shell release. Unfortunately I don't have a solution. If you are confident that it is clean and has been reassembled correctly I wouild contact OFM and see what they have to say.
 

shuter

Copper BB
Help! 930 JM Pro Bolt won't lock open now?

Guys, first post here. My new 930 JM Pro has an issue. Worked fine out of box, worked perfectly at the range for 50 rounds or so. Brought it back home and cleaned it. Then sent my lifter/trigger guard assy off to have the lifter welded. Came back very nice.

Plugged the Trigger/lifter assy back into gun and now bolt won't lock open when gun is cycled empty? Don't see anything in welding the tip of the lifter that would cause this? Could something in the reassembly of the trigger guard/lifter assy have caused it?

Thanks in advance.
 

rgg16g

Copper BB
GG&G forward sling mount causes loading issue

Hi all. First post and of course it is a problem post, sorry.

First I would like to say I love my 930 SPX. It has been very reliable, since about round 100 on, I have about 500 rounds down the pipe. I had one failure to extract during the 1st 100 rounds, it was a low brass field load. But since its run everything, so lets say 400 rounds no issues.

But on to my problem. I added the GG&G front sling attachment (see here http://www.gggaz.com/mossberg-930-front ... ments.html ) and with it installed it sometimes limits me to just 5 rounds (2 3/4) in the mag tube. The reasons seems obvious to me, the sling attachment is nothing more than a spacer between the mag extension and fix mag tube. This extension creates a gap that at least on my 930 allows, I believe, the rim of the shell to catch and thus limits me to 5 rounds. If I face into the wind and stand on one foot I can get 7 loaded but its not reliability accepting 7.

No biggie, I didn't like how the sling was oriented with this forward point anyway, SO the little guy is off the gun.

I was curious to hear if anyone else has had a similar, or different, experience.

Thanks
 
S

SHOOTER13

Guest
Re: GG&G forward sling mount causes loading issue

Welcome to the Mossberg Owners Forum rgg16ga !!
 

bzl

Copper BB
Re: GG&G forward sling mount causes loading issue

Greeting!

This is my first post on this forum. I have a 930 spx with pistol grip.

@rgg16g
Today afternoon, I got my GG&G front sling attachment similar to yours but with the QD attachment. I installed it and have the same problem. Sometimes the 5th round will not feed in to the tube and more frequently the 7th round will not go into the magazine tube fully. I have to remove the 7th round and try 2 or 3 times before it gets in. Then if the 7th round gets in many times it will not cycle into the chamber. All the rounds are 2.3/4 in length.

I agree with your assessment that the spacer might be causing a gap between the fixed magazine tube and the extension tube to cause the 5th round to get stuck. But i am unable to explain why the 7th round does not get in the tube and if it does on many occasion it does not cycle and load into the chamber.

Anyways on monday the front sling attachment point is going back to Botachtical. I will have to search around the forum to see what might be causing the 7th round to not load in to the chamber.

I was planning to use the VCAS sling with the 930 spx PG. But i guess it is to short for the set up. What sling are you planning to use on your 930 spx?
 
Re: GG&G forward sling mount causes loading issue

See my posts regarding the same problem without the sling adapter. I really believe they messed up in going with either the Choate extension and/or made the front of the hand guard too long.

I ground down the lip on the mag extension but still had problems. I noticed that the stock hand guard only allows 5 of the 6 threads to be exposed. So I hollowed out a recess for the mag extension to sit inside of the hand guard. Loaded and unloaded 20 times without issue.
 

tcecil88

.30-06
Elite Member
Re: GG&G forward sling mount causes loading issue

It would be nice if someone built an extension that had the sling loop attached in front of the knurled nut like the old Scattergun Technologies extensions. That would solve the problem with any gaps created by the adapter.
 

rgg16g

Copper BB
Re: GG&G forward sling mount causes loading issue

bzl said:
I was planning to use the VCAS sling with the 930 spx PG. But i guess it is to short for the set up. What sling are you planning to use on your 930 spx?

I have an extra Viking Tactics VTAC, which I used with the GG&G forward and rear sling mounts. When i took off the front sling mount I simply threaded both ends of the VTAC through the rear attachment point making kind of a makeshift single point sling. It actuly works pretty good! Its comfortable, hangs down nicely, and I can still use the quick adjust function of the sling. I might just leave it as is.
 
Top