• Mossberg Owners is in the process of upgrading the software. Please bear with us while we transition to the new look and new upgraded software.

Mossberg 835 Ulti-Mag Pump Action Troubleshooting

Mossybloke

.270 WIN
Re: RE: Broken 835

Ok, took the trigger assembly out and a BB had somehow wedged itself between the slide release lever and the trigger assembly housing preventing it from coming back down thus preventing the firing pin from functioning. Problem solved! I'm off to the skeet range...



Sent from my LG-C900 using Board Express
 

cheyne

Copper BB
835 hard to pump

Got a new 835 and it is hard to pump after fireing a shot even if you dry fire it. If you just work the action without fireing it is fine. I have taken it apart and cleaned it but that did not help. Any ideas
 

old mossy

Global Moderator
Staff member
Global Moderator
Moderator
Re: 835 hard to pump

cheyne said:
Got a new 835 and it is hard to pump after fireing a shot even if you dry fire it. If you just work the action without fireing it is fine. I have taken it apart and cleaned it but that did not help. Any ideas

Welcome to the forum from NY and congrats on your new Mossy. Sorry to hear about the problem.
I would take a good look at the bolt and trigger assembly.
Also look at the inside of the receiver for any gouge type marks.

Keep us posted.
 

ripjack13

Resident Sawdust Maker
Staff member
Administrator
Supporter
"Philanthropist"
Re: 835 hard to pump

New ones shouldn't be hard to cycle ...since you have takenit apart you now have an idea ofthe way it goes back together. Like ol mossy said....check it out again. Look for burrs or anything that would hinder it....
 

flightsimmer

Copper BB
I have the Mossberg 835 Ulti-Mag and it works fine but! When I shoot 3-1/2" loads which is seldom the action opens on it's own, I have tried holding the action closed when I fire it but it still opens. If I don't hold it shut it opens and ejects the shell. Now this does not seem to be the case when I shoot 2-2/4" or 3" shells. It seems to lock up tight, that is I cannot force it open with the fore end. I guess I could take it apart and look it over but what should I be looking for?
 

ripjack13

Resident Sawdust Maker
Staff member
Administrator
Supporter
"Philanthropist"
Taking it apart always helps figure things out. As well as how it goes together. However, one question first....when you are shouldered up with it, how is your grip on the forearm? Are you pulling it into your shoulder or pushing out slightly?
If you have a shooting partner, ask him/her to watch you when you shoot and what you are doing when it happens. You can also record yourself to see.
Checking on that first eliminates operator malfuntion. Then we can open er up and see what's what....
 

flightsimmer

Copper BB
Quote; when you are shouldered up with it, how is your grip on the forearm? Are you pulling it into your shoulder or pushing out slightly?/quote.

I have fired it when pushing forward on the forearm and I have fired it when not touching the forearm at all, that's when it ejects the shell on it's own.
3-1/2" Magnums are not the kind of round that you practice or test very often. I fired several 2-3/4" and 3" rounds and switched barrels to the rifled slug barrel to sight them in then switched back to the smooth barrel and before I left the range I decided to shoot a few of the 3-1/2" loads, BIG! mistake, my shoulder was already sore and that didn't help a bit. but I was surprised that the action opened on it's own so I tried a couple more as I finished off the box and it opened every time no matter how I held it.
 

1shot

Copper BB
Hello all,
I'm new here as I need some help in repairing an 835 turkey gun for a guy at work. He drops it in my lap and says fix this xxxx thing. Is won't feed the shells he tells me, so I take it to my shop and the rt. shell latch isn't being pushed far enough outboard to allow the shell to release from the magazine tube and be picked up by the elevator. Using inert rounds I can make it work manually, by "pre-staging" the shell latch. Also, when ejecting the round it seems really lame as opposed to how crisp most other pump guns are. I have totally dis-assembled the shotgun and it appears to be in like new, unfired condition. Can someone steer me in the right direction?
Thanks,
Lloyd
 

old mossy

Global Moderator
Staff member
Global Moderator
Moderator
Hello Llyod. Welcome to the forum from NY. Sorry to hear your buddy is having a problem.
Sounds like the cartridge interrupter.(its been a problem with some Mossbergs lately.)

Here's a great link about the problem which can be fixed with some patients and a bit of bending.

viewtopic.php?f=34&t=8835&start=25
 

ER6000

Copper BB
Hi guys,

I'm new to the forum.

I've owned an 835 Ulti-Mag for several years now. Every once in a while, maybe every 20-30 rounds, a new/unfired shell will be ejected out of the bottom loading port when the slide is moved to eject one shell and load another. It typically happens on the second shot, so over three shots I'll get bang, click, and another bang. I've tried a good cleaning and that doesn't seem to help.

Have any of you heard of this or experienced this? If so, do you have a solution?

Thanks,
Erik
 

old mossy

Global Moderator
Staff member
Global Moderator
Moderator
Welcome to the forum from NY. Sorry to hear your having a problem. Sounds like the cartridge interrupter is hanging up once in awhile and letting a shell drop out the bottom.
Check the position in the pic. You might have to fine tune yours with a slight bend.
Keep us posted.

cartridge good cartridge stop.jpg
 

ER6000

Copper BB
Welcome to the forum from NY. Sorry to hear your having a problem. Sounds like the cartridge interrupter is hanging up once in awhile and letting a shell drop out the bottom.
Check the position in the pic. You might have to fine tune yours with a slight bend.
Keep us posted.

View attachment 5646
Hey thanks!

Yeah, mine was off some. Tweaked it and will do some shooting when it warms up. Will let you know how it works out.

Thanks again!
 

old mossy

Global Moderator
Staff member
Global Moderator
Moderator
@ER6000 I just want to correct my above post I meant the cartridge stop, the one on the left side of the receiver.
Sorry about that.:oops:
 

lasl

Copper BB
good day all i'm new to this forum .I have a problem with my 835 .i will load a shell im the chamber and i will loose the next one and i get a bang after on 3 shel i always loose one minimum i need some help here please
 

ripjack13

Resident Sawdust Maker
Staff member
Administrator
Supporter
"Philanthropist"
Howdy @lasl welcome to club.

Could you explain a little more of the situation? If I understand it correctly, you're loading 3 shells in the tube, and are attempting to chamber a round and it is not firing on the next load? Everytime?

What are you using for shells?
How long long have you had the 835?
Is it new or used?
Have you ever cleaned yet? Especially before firing it...
 

lasl

Copper BB
Good day has I try to explain the first time. I have a 835 ultimag and I keep losing round’s. I put the first round directly in the chamber and load the next 2 in the mag tube. I will fire the first round pump the action and the next round falling on the ground pump again and the next one go in this happen every time can someone help me finding the problem.

i use 3 and 2 3/4 round .
i have the gun for 1 1/2 year
and i bought it use
and yes i cleaned it at lease tryed on the best of my knowledge
 
Last edited:
Top